#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+(?:\.\d+)*\b"
Local $sString = "1.2.3" & @CRLF & _
"1.4.0.136" & @CRLF & _
"V312" & @CRLF & _
"V10" & @CRLF & _
"2.2.2" & @CRLF & _
"r1elease2.0.0" & @CRLF & _
"Vr 1.5.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")