import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:\\.\\d+)*\\b";
final String string = "1.2.3\n"
+ "1.4.0.136\n"
+ "V312\n"
+ "V10\n"
+ "2.2.2\n"
+ "r1elease2.0.0\n"
+ "Vr 1.5.1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}