import re
regex = re.compile(r"\d+(?:\.\d+)*\b")
test_str = ("1.2.3\n"
"1.4.0.136\n"
"V312\n"
"V10\n"
"2.2.2\n"
"r1elease2.0.0\n"
"Vr 1.5.1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")