#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^a-z]{1,}[A-Z]{2,}+)(?:(?! - C[oó]pia\.[^.]+).)+$"
Local $sString = "EDSON ARANTES DO NASCIMENTO.jpg" & @CRLF & _
"EDsON ARANTEs DO NASCIMENTO.jpg" & @CRLF & _
"EDSON ARANTES DO NASCIMENTO - Cópia.jpg" & @CRLF & _
"EDSON ARANTES DO NASCIMENTO - Cópia - Cópia.jpg "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")