$re = '/^([^a-z]{1,}[A-Z]{2,}+)(?:(?! - C[oó]pia\.[^.]+).)+$/m';
$str = 'EDSON ARANTES DO NASCIMENTO.jpg
EDsON ARANTEs DO NASCIMENTO.jpg
EDSON ARANTES DO NASCIMENTO - Cópia.jpg
EDSON ARANTES DO NASCIMENTO - Cópia - Cópia.jpg ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);