use strict;
my $str = 'EDSON ARANTES DO NASCIMENTO.jpg
EDsON ARANTEs DO NASCIMENTO.jpg
EDSON ARANTES DO NASCIMENTO - Cópia.jpg
EDSON ARANTES DO NASCIMENTO - Cópia - Cópia.jpg ';
my $regex = qr/^([^a-z]{1,}[A-Z]{2,}+)(?:(?! - C[oó]pia\.[^.]+).)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}