#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "ggg"
Local $sString = "The_Hink" & @CRLF & _
"8" & @CRLF & _
"G" & @CRLF & _
"Mr.Lol https://namemc.com/profile/Mr.LoL/6e27dd0e" & @CRLF & _
"$ https://namemc.com/profile/$/dce40453" & @CRLF & _
"" & @CRLF & _
"^(?![0-9a-zA-Z\_]{1,16}.)*$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[Admin] Hink" & @CRLF & _
" [Mod] Hink" & @CRLF & _
"asd [] asd" & @CRLF & _
"[] Nigger" & @CRLF & _
"[[ ]]" & @CRLF & _
"][" & @CRLF & _
"" & @CRLF & _
".*?[\[](.+)?[\]].*" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^([^a-zA-Z0-9]*|.*[^a-zA-Z0-9]*)?[\h\H\Ĥ\ĥ\Ħ\ħ][^a-zA-Z0-9]*[\i\I\!\|\Ì\ì\Í\í\Î\î\Ï\ï\!\|][^a-zA-Z0-9]*[\n\N\Ń\ń\Ņ\ņ\Ň\ň\ʼn\Ŋ\ŋ][^a-zA-Z0-9]*[\k\K\Ķ\ķ\ĸ].*?$" & @CRLF & _
"hink" & @CRLF & _
"Hink" & @CRLF & _
"HiNk" & @CRLF & _
"hnk" & @CRLF & _
"think" & @CRLF & _
" hink" & @CRLF & _
"-hink_" & @CRLF & _
"h-i-n-k" & @CRLF & _
"h i n k" & @CRLF & _
"kys hink" & @CRLF & _
"idk hink what's up?" & @CRLF & _
"stop being a nif" & @CRLF & _
"t hink" & @CRLF & _
"2 2 hi___nk 22" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^([^a-zA-Z0-9]*|(.*[^a-zA-Z0-9]+))?[hH\Ĥ\ĥ\Ħ\ħ][^a-zA-Z0-9]*[iI!|\Ì\ì\Í\í\î\Ï\ï][^a-zA-Z0-9]*[nN\Ń\ń\Ņ\ņ\Ň\ň\ʼn\Ŋ\ŋ][^a-zA-Z0-9]*[kK\Ķ\ķ\ĸ].*$" & @CRLF & _
"Hink" & @CRLF & _
"hink" & @CRLF & _
"think" & @CRLF & _
"hink is cunt" & @CRLF & _
"lick my cunt hink" & @CRLF & _
"h - ink" & @CRLF & _
" h ---inK+_" & @CRLF & _
"ĤÏNķ" & @CRLF & _
"think" & @CRLF & _
"sticky hinky" & @CRLF & _
"" & @CRLF & _
"^[\h\H\Ĥ\ĥ\Ħ\ħ][\i\I\!\|\Ì\ì\Í\í\Î\î\Ï\ï][\n\N\Ń\ń\Ņ\ņ\Ň\ň\ʼn\Ŋ\ŋ][\k\K\Ķ\ķ\ĸ]$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^.*[\\ㅤ\ᅠ\ᅠ\ᅟ].*$" & @CRLF & _
"" & @CRLF & _
"^.*[\u2062\u3164\uFFA0\u1160\u115F].*$" & @CRLF & _
"http://www.fileformat.info/info/unicode/char/2062/index.htm: """ & @CRLF & _
"http://www.fileformat.info/info/unicode/char/3164/index.htm: "ㅤ"" & @CRLF & _
"http://www.fileformat.info/info/unicode/char/ffa0/index.htm: "ᅠ"" & @CRLF & _
"http://www.fileformat.info/info/unicode/char/1160/index.htm: "ᅠ"" & @CRLF & _
"http://www.fileformat.info/info/unicode/char/115f/index.htm: "ᅟ"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^([^a-zA-Z0-9]*|(.*[^a-zA-Z0-9]+))?[hH][^a-zA-Z0-9]*[iI!][^a-zA-Z0-9]*[nN][^a-zA-Z0-9]*[kK].*$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")