use strict;
my $str = 'The_Hink
8
G
Mr.Lol https://namemc.com/profile/Mr.LoL/6e27dd0e
$ https://namemc.com/profile/$/dce40453
^(?![0-9a-zA-Z\\_]{1,16}.)*$
[Admin] Hink
[Mod] Hink
asd [] asd
[] Nigger
[[ ]]
][
.*?[\\[](.+)?[\\]].*
^([^a-zA-Z0-9]*|.*[^a-zA-Z0-9]*)?[\\h\\H\\Ĥ\\ĥ\\Ħ\\ħ][^a-zA-Z0-9]*[\\i\\I\\!\\|\\Ì\\ì\\Í\\í\\Î\\î\\Ï\\ï\\!\\|][^a-zA-Z0-9]*[\\n\\N\\Ń\\ń\\Ņ\\ņ\\Ň\\ň\\ʼn\\Ŋ\\ŋ][^a-zA-Z0-9]*[\\k\\K\\Ķ\\ķ\\ĸ].*?$
hink
Hink
HiNk
hnk
think
hink
-hink_
h-i-n-k
h i n k
kys hink
idk hink what\'s up?
stop being a nif
t hink
2 2 hi___nk 22
^([^a-zA-Z0-9]*|(.*[^a-zA-Z0-9]+))?[hH\\Ĥ\\ĥ\\Ħ\\ħ][^a-zA-Z0-9]*[iI!|\\Ì\\ì\\Í\\í\\î\\Ï\\ï][^a-zA-Z0-9]*[nN\\Ń\\ń\\Ņ\\ņ\\Ň\\ň\\ʼn\\Ŋ\\ŋ][^a-zA-Z0-9]*[kK\\Ķ\\ķ\\ĸ].*$
Hink
hink
think
hink is cunt
lick my cunt hink
h - ink
h ---inK+_
ĤÏNķ
think
sticky hinky
^[\\h\\H\\Ĥ\\ĥ\\Ħ\\ħ][\\i\\I\\!\\|\\Ì\\ì\\Í\\í\\Î\\î\\Ï\\ï][\\n\\N\\Ń\\ń\\Ņ\\ņ\\Ň\\ň\\ʼn\\Ŋ\\ŋ][\\k\\K\\Ķ\\ķ\\ĸ]$
^.*[\\\\ㅤ\\ᅠ\\ᅠ\\ᅟ].*$
^.*[\\u2062\\u3164\\uFFA0\\u1160\\u115F].*$
http://www.fileformat.info/info/unicode/char/2062/index.htm: ""
http://www.fileformat.info/info/unicode/char/3164/index.htm: "ㅤ"
http://www.fileformat.info/info/unicode/char/ffa0/index.htm: "ᅠ"
http://www.fileformat.info/info/unicode/char/1160/index.htm: "ᅠ"
http://www.fileformat.info/info/unicode/char/115f/index.htm: "ᅟ"
^([^a-zA-Z0-9]*|(.*[^a-zA-Z0-9]+))?[hH][^a-zA-Z0-9]*[iI!][^a-zA-Z0-9]*[nN][^a-zA-Z0-9]*[kK].*$
';
my $regex = qr/ggg/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}