import re
regex = re.compile(r"ggg")
test_str = ("The_Hink\n"
"8\n"
"G\n"
"Mr.Lol https://namemc.com/profile/Mr.LoL/6e27dd0e\n"
"$ https://namemc.com/profile/$/dce40453\n\n"
"^(?![0-9a-zA-Z\\_]{1,16}.)*$\n\n\n\n"
"[Admin] Hink\n"
" [Mod] Hink\n"
"asd [] asd\n"
"[] Nigger\n"
"[[ ]]\n"
"][\n\n"
".*?[\\[](.+)?[\\]].*\n\n\n\n"
"^([^a-zA-Z0-9]*|.*[^a-zA-Z0-9]*)?[\\h\\H\\Ĥ\\ĥ\\Ħ\\ħ][^a-zA-Z0-9]*[\\i\\I\\!\\|\\Ì\\ì\\Í\\í\\Î\\î\\Ï\\ï\\!\\|][^a-zA-Z0-9]*[\\n\\N\\Ń\\ń\\Ņ\\ņ\\Ň\\ň\\ʼn\\Ŋ\\ŋ][^a-zA-Z0-9]*[\\k\\K\\Ķ\\ķ\\ĸ].*?$\n"
"hink\n"
"Hink\n"
"HiNk\n"
"hnk\n"
"think\n"
" hink\n"
"-hink_\n"
"h-i-n-k\n"
"h i n k\n"
"kys hink\n"
"idk hink what's up?\n"
"stop being a nif\n"
"t hink\n"
"2 2 hi___nk 22\n\n\n\n\n\n"
"^([^a-zA-Z0-9]*|(.*[^a-zA-Z0-9]+))?[hH\\Ĥ\\ĥ\\Ħ\\ħ][^a-zA-Z0-9]*[iI!|\\Ì\\ì\\Í\\í\\î\\Ï\\ï][^a-zA-Z0-9]*[nN\\Ń\\ń\\Ņ\\ņ\\Ň\\ň\\ʼn\\Ŋ\\ŋ][^a-zA-Z0-9]*[kK\\Ķ\\ķ\\ĸ].*$\n"
"Hink\n"
"hink\n"
"think\n"
"hink is cunt\n"
"lick my cunt hink\n"
"h - ink\n"
" h ---inK+_\n"
"ĤÏNķ\n"
"think\n"
"sticky hinky\n\n"
"^[\\h\\H\\Ĥ\\ĥ\\Ħ\\ħ][\\i\\I\\!\\|\\Ì\\ì\\Í\\í\\Î\\î\\Ï\\ï][\\n\\N\\Ń\\ń\\Ņ\\ņ\\Ň\\ň\\ʼn\\Ŋ\\ŋ][\\k\\K\\Ķ\\ķ\\ĸ]$\n\n\n"
"^.*[\\\\ㅤ\\ᅠ\\ᅠ\\ᅟ].*$\n\n"
"^.*[\\u2062\\u3164\\uFFA0\\u1160\\u115F].*$\n"
"http://www.fileformat.info/info/unicode/char/2062/index.htm: \"\"\n"
"http://www.fileformat.info/info/unicode/char/3164/index.htm: \"ㅤ\"\n"
"http://www.fileformat.info/info/unicode/char/ffa0/index.htm: \"ᅠ\"\n"
"http://www.fileformat.info/info/unicode/char/1160/index.htm: \"ᅠ\"\n"
"http://www.fileformat.info/info/unicode/char/115f/index.htm: \"ᅟ\"\n\n\n"
"^([^a-zA-Z0-9]*|(.*[^a-zA-Z0-9]+))?[hH][^a-zA-Z0-9]*[iI!][^a-zA-Z0-9]*[nN][^a-zA-Z0-9]*[kK].*$\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")