package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*/([^_]+).*`)
var str = `2019/01/01/07/556662_cba3a4fc-cb8f-4150-859f-5f21a38373d0`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}