$re = '~.*/([^_]+).*~m';
$str = '2019/01/01/07/556662_cba3a4fc-cb8f-4150-859f-5f21a38373d0';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;