#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^@ ]+(?=[#>])"
Local $sString = "Case 1: HOSTNAME#" & @CRLF & _
"Case 2: HOSTNAME>" & @CRLF & _
"Case 3: myid8@HOSTNAME>" & @CRLF & _
"Case 4: myid8@HOSTNAME# "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")