re = /[^@ ]+(?=[#>])/m
str = 'Case 1: HOSTNAME#
Case 2: HOSTNAME>
Case 3: myid8@HOSTNAME>
Case 4: myid8@HOSTNAME# '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end