import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^@ ]+(?=[#>])";
final String string = "Case 1: HOSTNAME#\n"
+ "Case 2: HOSTNAME>\n"
+ "Case 3: myid8@HOSTNAME>\n"
+ "Case 4: myid8@HOSTNAME# ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}