using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ref name=""?((?:[^"">\/]|\/(?!>))*?)""? *\/?>";
string input = @"<ref name=Test1/>
<ref name=Test2 />
<ref name=""Test3""/>
<ref name=""Test4"" />
<ref name=Test5>Foo</ref>
<ref name=""Test6"">Foo</ref>
<ref name=Te/st7/>
<ref name=Te/st8 />
<ref name=""Te/st9""/>
<ref name=""Te/st10"" />
<ref name=Te/st11>Foo</ref>
<ref name=""Te/st12"">Foo</ref>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}