$re = '/<ref name="?((?:[^">\/]|\/(?!>))*?)"? *\/?>/m';
$str = '<ref name=Test1/>
<ref name=Test2 />
<ref name="Test3"/>
<ref name="Test4" />
<ref name=Test5>Foo</ref>
<ref name="Test6">Foo</ref>
<ref name=Te/st7/>
<ref name=Te/st8 />
<ref name="Te/st9"/>
<ref name="Te/st10" />
<ref name=Te/st11>Foo</ref>
<ref name="Te/st12">Foo</ref>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);