const regex = /0*(\d+\.0?\d*?)0*(\D|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0*(\\d+\\.0?\\d*?)0*(\\D|$)', 'gm')
const str = `7.315200
21.234400
20.450000
0.000000
90.0
0.0
0.500000
1.000000
20.95
5.3
0.00001
7.30
0.86603
0.0234501231000
100.0
000123.000456000
010
00102030.405060
00001.0`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);