import Foundation
let pattern = #"0*(\d+\.0?\d*?)0*(\D|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
7.315200
21.234400
20.450000
0.000000
90.0
0.0
0.500000
1.000000
20.95
5.3
0.00001
7.30
0.86603
0.0234501231000
100.0
000123.000456000
010
00102030.405060
00001.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)