# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"0*(\d+\.0?\d*?)0*(\D|$)"
test_str = ("7.315200\n"
"21.234400\n"
"20.450000\n"
"0.000000\n"
"90.0\n"
"0.0\n"
"0.500000\n"
"1.000000\n"
"20.95\n"
"5.3\n"
"0.00001\n"
"7.30\n"
"0.86603\n"
"0.0234501231000\n"
"100.0\n"
"000123.000456000\n"
"010\n"
"00102030.405060\n"
"00001.0")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.