re = /^([A-Z0-9]{16})$/m
str = 'Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end