#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{10,255}$)(?:0x)?[0-9a-fA-F]{2}(?:[0-9a-fA-F]{2})*$"
Local $sString = "Accepted" & @CRLF & _
"0x1234567890" & @CRLF & _
"1234567890" & @CRLF & _
"0x123456789012" & @CRLF & _
"123456789012" & @CRLF & _
"" & @CRLF & _
"Rejected" & @CRLF & _
"0x123456789" & @CRLF & _
"123456789" & @CRLF & _
"12345678901" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")