re = /^(?=.{10,255}$)(?:0x)?[0-9a-fA-F]{2}(?:[0-9a-fA-F]{2})*$/m
str = 'Accepted
0x1234567890
1234567890
0x123456789012
123456789012
Rejected
0x123456789
123456789
12345678901
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end