import re
regex = re.compile(r"^(?=.{10,255}$)(?:0x)?[0-9a-fA-F]{2}(?:[0-9a-fA-F]{2})*$", flags=re.MULTILINE)
test_str = ("Accepted\n"
"0x1234567890\n"
"1234567890\n"
"0x123456789012\n"
"123456789012\n\n"
"Rejected\n"
"0x123456789\n"
"123456789\n"
"12345678901\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")