const regex = /(?:Solution:)?\s*(?:\d+\. )?(.+?)(?=\n(?:Solution:|\d+\. )|\Z)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:Solution:)?\\s*(?:\\d+\\. )?(.+?)(?=\\n(?:Solution:|\\d+\\. )|\\Z)', 'gms')
const str = `Solution: To create a Nextflow configuration file, follow these steps:
1. Create a new file named \`nextflow.config\` in the project directory.
2. Declare the configuration options by using the \`params\` keyword followed by variable names and their default values. For example:
\`\`\`
params {
inputDir = './input'
outputDir = './output'
numThreads = 4
}
\`\`\`
3. You can also override the default values in the configuration file by specifying new values when running the pipeline. For example:
\`\`\`
nextflow run my_pipeline.nf --inputDir /path/to/input --outputDir /path/to/output --numThreads 8
\`\`\`
4. Save the file and use it in your pipeline by calling the parameter name with the \`\$\` symbol. For example:
\`\`\`
process myProcess {
input:
file fastq from "\$inputDir/*_R{1,2}.fastq.gz"
output:
file("\${outputDir}/\${sampleName}_mapped.bam")
script:
"""
my_command --input \$fastq --threads \$numThreads --output \${outputDir}/\${sampleName}_mapped.bam
"""
}
\`\`\`
Next request.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}