import re
regex = re.compile(r"(?:Solution:)?\s*(?:\d+\. )?(.+?)(?=\n(?:Solution:|\d+\. )|\Z)", flags=re.MULTILINE | re.DOTALL)
test_str = ("Solution: To create a Nextflow configuration file, follow these steps:\n\n"
"1. Create a new file named `nextflow.config` in the project directory.\n"
"2. Declare the configuration options by using the `params` keyword followed by variable names and their default values. For example:\n\n"
"```\n"
"params {\n"
" inputDir = './input'\n"
" outputDir = './output'\n"
" numThreads = 4\n"
"}\n"
"```\n\n"
"3. You can also override the default values in the configuration file by specifying new values when running the pipeline. For example:\n\n"
"```\n"
"nextflow run my_pipeline.nf --inputDir /path/to/input --outputDir /path/to/output --numThreads 8\n"
"```\n\n"
"4. Save the file and use it in your pipeline by calling the parameter name with the `$` symbol. For example:\n\n"
"```\n"
"process myProcess {\n"
" input:\n"
" file fastq from \"$inputDir/*_R{1,2}.fastq.gz\"\n"
" output:\n"
" file(\"${outputDir}/${sampleName}_mapped.bam\")\n"
" script:\n"
" \"\"\"\n"
" my_command --input $fastq --threads $numThreads --output ${outputDir}/${sampleName}_mapped.bam\n"
" \"\"\"\n"
"}\n"
"```\n\n"
"Next request.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")