re = /(?:Solution:)?\s*(?:\d+\. )?(.+?)(?=\n(?:Solution:|\d+\. )|\Z)/m
str = 'Solution: To create a Nextflow configuration file, follow these steps:
1. Create a new file named `nextflow.config` in the project directory.
2. Declare the configuration options by using the `params` keyword followed by variable names and their default values. For example:
```
params {
inputDir = \'./input\'
outputDir = \'./output\'
numThreads = 4
}
```
3. You can also override the default values in the configuration file by specifying new values when running the pipeline. For example:
```
nextflow run my_pipeline.nf --inputDir /path/to/input --outputDir /path/to/output --numThreads 8
```
4. Save the file and use it in your pipeline by calling the parameter name with the `$` symbol. For example:
```
process myProcess {
input:
file fastq from "$inputDir/*_R{1,2}.fastq.gz"
output:
file("${outputDir}/${sampleName}_mapped.bam")
script:
"""
my_command --input $fastq --threads $numThreads --output ${outputDir}/${sampleName}_mapped.bam
"""
}
```
Next request.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end