#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(text\]) (?:\[option1/option2\]) (\[text)?|(?:\[option1/option2\]) (\[text)"
Local $sString = "text [option1/option2] text" & @CRLF & _
"text] [option1/option2] more text" & @CRLF & _
"text [option1/option2] [text" & @CRLF & _
"text] [option1/option2] [text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")