package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(text\]) (?:\[option1/option2\]) (\[text)?|(?:\[option1/option2\]) (\[text)`)
var str = `text [option1/option2] text
text] [option1/option2] more text
text [option1/option2] [text
text] [option1/option2] [text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}