$re = '/(text\]) (?:\[option1/option2\]) (\[text)?|(?:\[option1/option2\]) (\[text)/m';
$str = 'text [option1/option2] text
text] [option1/option2] more text
text [option1/option2] [text
text] [option1/option2] [text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);