#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w (?=[0-9])\d(?![0-9]|[a-z])"
Local $sString = "He is 8 or 9 years old, not 10." & @CRLF & _
"I like 7up." & @CRLF & _
"It's 20 past 3" & @CRLF & _
"example 1, example 2" & @CRLF & _
"Definitely 9." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")