using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w (?=[0-9])\d(?![0-9]|[a-z])";
string input = @"He is 8 or 9 years old, not 10.
I like 7up.
It's 20 past 3
example 1, example 2
Definitely 9.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}