$re = '/\w (?=[0-9])\d(?![0-9]|[a-z])/m';
$str = 'He is 8 or 9 years old, not 10.
I like 7up.
It\'s 20 past 3
example 1, example 2
Definitely 9.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);