using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0?(1[89]|[2-9]\d)$";
string input = @"18
018
17
017
99
099
100
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}