$re = '/^0?(1[89]|[2-9]\d)$/m';
$str = '18
018
17
017
99
099
100
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);