package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0?(1[89]|[2-9]\d)$`)
var str = `18
018
17
017
99
099
100
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}