$re = '/(?s)^((?:https?://)?(?:www\.)?\S+\.\S+)\n(?=.*^\1$)/m';
$str = 'operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
amazon.de
fonts.gstatic.com
fonts.gstatic.com
fonts.gstatic.com
erovoyeurism.net
tugtechnologyandbusiness.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;