re = /(?s)^((?:https?:\/\/)?(?:www\.)?\S+\.\S+)\n(?=.*^\1$)/m
str = 'operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
operator.livrareflori.md
amazon.de
fonts.gstatic.com
fonts.gstatic.com
fonts.gstatic.com
erovoyeurism.net
tugtechnologyandbusiness.com'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result