package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+|\D+`)
var str = `st99nd99d`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}