const regex = new RegExp('\\d+|\\D+', 'g')
const str = `st99nd99d`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);