use strict;
my $str = 'st99nd99d';
my $regex = qr/\d+|\D+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";