using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)[a-z]*[\d]+[a-z]*[\-{1}][a-z]*[\d]+[a-z]*";
string input = @"1033A-1033D
12A-12B
A12-12A
A12-B12
11E-24E
1A-1B
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}