import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)[a-z]*[\\d]+[a-z]*[\\-{1}][a-z]*[\\d]+[a-z]*";
final String string = "1033A-1033D\n"
+ "12A-12B\n"
+ "A12-12A\n"
+ "A12-B12\n"
+ "11E-24E\n"
+ "1A-1B\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}