re = /(?i)[a-z]*[\d]+[a-z]*[\-{1}][a-z]*[\d]+[a-z]*/mi
str = '1033A-1033D
12A-12B
A12-12A
A12-B12
11E-24E
1A-1B
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end