using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{12}(?:00[1-9]|0[1-9]\d|[1-9]\d\d)$";
string input = @"123412341234001";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}