package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#\w+|[^#\s][^\s#]*(?:\s+[^#\s][^\s#]*)*`)
var str = `привет #username text text #username2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}