re = /#\w+|[^#\s][^\s#]*(?:\s+[^#\s][^\s#]*)*/
str = 'привет #username text text #username2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end