import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.* out: Built|published ).*$";
final String string = "Console ouput\n"
+ "published xyz\n"
+ "[servername] out: Built 123abcwxyabjd\n"
+ "few lines of o/p\n"
+ "[servername2] out: Built ewrewfdsfabcwxyabjd\n"
+ "again some o/p\n"
+ "[servername3] out: Built 1458543abcwxyabjd\n"
+ "published abc\n"
+ "some o/p\n"
+ "[servername2] out: Built dfds123abcwxyabjd\n"
+ "some o/p\n"
+ "[servername] out: Built dsfdsabcwxyabjd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}