# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.* out: Built|published ).*$"
test_str = ("Console ouput\n"
"published xyz\n"
"[servername] out: Built 123abcwxyabjd\n"
"few lines of o/p\n"
"[servername2] out: Built ewrewfdsfabcwxyabjd\n"
"again some o/p\n"
"[servername3] out: Built 1458543abcwxyabjd\n"
"published abc\n"
"some o/p\n"
"[servername2] out: Built dfds123abcwxyabjd\n"
"some o/p\n"
"[servername] out: Built dsfdsabcwxyabjd")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.