using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*told me to say.*";
string input = @"ex1: I am * years old
valid matches:
- ""I am 24 years old""
- ""I am twenty four years old""
ex2: what color is [my|your|his|her] (bright red|blue|green|lemon chiffon) *
valid matches:
- ""what color is his lemon chiffon car""
- ""what color is my some random text till the end of string""
ex3: [*] told me to say *
valid matches:
- ""Bob and Alice told me to say hallelujah""
- ""told me to say by nobody""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}