// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*told me to say.*").unwrap();
let string = "ex1: I am * years old
valid matches:
- \"I am 24 years old\"
- \"I am twenty four years old\"
ex2: what color is [my|your|his|her] (bright red|blue|green|lemon chiffon) *
valid matches:
- \"what color is his lemon chiffon car\"
- \"what color is my some random text till the end of string\"
ex3: [*] told me to say *
valid matches:
- \"Bob and Alice told me to say hallelujah\"
- \"told me to say by nobody\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}